Reply To: can't vibrate

Home Forums OpenEars can't vibrate Reply To: can't vibrate

Halle Winkler

Welcome! I apologize for the delay in answering you. The reason that AudioSessionManager no longer needs to be directly accessed is that mixing is now set by default. There is also a mixing setting as part of OEPocketsphinxController if you check out its header. It is possible that in addition to mixing (which you shouldn’t have to change because it now defaults to mixing=YES) you also have to set audioMode = @”VoiceChat” in order to have system sounds (including vibrate, which for whatever reason is dependent on system sounds) working.