I can’t get app worked when I set .mm for ViewController on XCode 10.0.

Home Forums OpenEars plugins I can’t get app worked when I set .mm for ViewController on XCode 10.0.

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)

  • Author
    Posts
  • #1032555

    altima
    Participant

    Hello!
    I can’t get app worked when I set .mm for ViewController on XCode 10.0. I get error: “clang:-1: linker command failed with exit code 1 (use -v to see invocation)”. On XCode 9 it worked good.
    When I rename ViewController to .m, app works, but I not sure that it will work correct.
    Also I get 11 warnings: “Semantic Issue Group. This function declaration is not a prototype”.
    Could you explain, will app work correct with .m extension and if not, how to fix this? Do you plan to fix warnings?

    #1032557

    Halle Winkler
    Politepix

    Welcome,

    Thanks for this information. Unfortunately, I won’t be able to look into the issue until after the 15th; I apologize for the delay but it is currently unavoidable.

    In the meantime, to make it possible to fix quickly once I am able to look into it, please check out the post Please read before you post – how to troubleshoot and provide logging info here so you can see how to turn on and share the logging that provides troubleshooting information for this kind of issue. There will be a complete error in our build log which you can share, and you can also provide important missing information such as which OpenEars plugin this question is about, which version it is, which version of OpenEars you are using, etc.

    If you want to attempt to troubleshoot the error yourself in the meantime, you can look at the full error you receive in the build log, and then most likely link to a current and supported c++ library in your build settings, since my best guess without being able to look into it is that you have carried forward an older unsupported c++ library that Xcode 10 no longer supports. Good luck if you want to give that a try, and I will check into this as soon as it is possible to do so; thanks for your patience.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.