NeatSpeech Bluetooth Settings

Home Forums OpenEars plugins NeatSpeech Bluetooth Settings

Viewing 5 posts - 1 through 5 (of 5 total)

  • Author
    Posts
  • #1031802

    apbmedia
    Participant

    Hi there, I am developing an app which connects to the in car bluetooth to make outgoing calls.

    We use speech commands to activate the call and also some words are read back to us using NeatSpeech.

    When we set the sample rate to 48kHz the voice seems very thin.
    When we set the sample rate to 16kHz the voice seems very slow.

    How can I calculate the optimal settings for speech and voice recognition for my app?

    Thanks

    APB

    #1031803

    Halle Winkler
    Politepix

    Welcome,

    The difficulty of supporting issues like this with different configurations is the reason that bluetooth support is considered experimental, so support for this kind of question is very limited as a consequence, however, please check out the OEPocketsphinxController property disablePreferredSampleRate (and related audio session properties) to see if they improve results for you, making sure that the OEPocketsphinxController instance is active before attempting to set its properties.

    #1031804

    apbmedia
    Participant

    Thanks but I just wanted a little help with increasing the quality without speeding up the speech. E.g. after I increase the sample rate do I need to decrease speed?

    Thanks

    APB

    #1031805

    apbmedia
    Participant

    We have already activated this controller with the following settings:

    ////
    [[OEPocketsphinxController sharedInstance] setActive:TRUE error:nil]; // Call this before setting any OEPocketsphinxController characteristics

    [[OEPocketsphinxController sharedInstance] setDisablePreferredSampleRate:YES];
    [[OEPocketsphinxController sharedInstance] setDisablePreferredBufferSize:YES];
    [[OEPocketsphinxController sharedInstance] setDisablePreferredChannelNumber:YES];

    Since we did this, voice quality seems very low.

    Can it be fixed?

    • This reply was modified 1 year, 7 months ago by  apbmedia.
    #1031807

    Halle Winkler
    Politepix

    Hi,

    I wasn’t recommending that you set them all, just recommending that since this isn’t a supported configuration, you give the header a read-through and try and see which settings may help you (I would expect that the most-relevant properties to your question are regarding session mixing and disabling sample rate setting). Sorry, there is no recipe for this situation because it isn’t supported by this project – there are some existing hooks to give you some influence over the behavior of the audio session and it is necessary to do self-directed investigation into whether they help with your issue.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘NeatSpeech Bluetooth Settings’ is closed to new replies.